Arizona All Nissan Club

Club Garage => Xterra Garage => Topic started by: mjepps72 on February 10, 2013, 04:32:40 PM

Title: 04 XE 2WD Build Log
Post by: mjepps72 on February 10, 2013, 04:32:40 PM
Yet another build thread where I will be keeping track of my progress over time.

Purchased a 04 XE 2WD in January 2013 and have been reading damn near every DIY thread on here. I have already done a few mods and will start this thread by posting a few pics of those first then continue on from there.

Here is the first pic I have a few minutes after I got her home.
(http://www.mjepps.com/xterra/2013-01-15%2017.48.01.jpg)

First thing I did was add some stickers to give it the obvious HP increase  :)
(http://www.mjepps.com/xterra/2013-01-22%2016.41.34.jpg)
(http://www.mjepps.com/xterra/2013-02-10%2007.43.12.jpg)

I did the airbox mod the first weekend after purchasing it. I used PVC caps to seal off the two holes instead.
(http://www.mjepps.com/xterra/2013-01-20%2016.52.48.jpg)

I just recently added a bull bar and HID lights.
(http://www.mjepps.com/xterra/2013-02-02%2008.41.58.jpg)

Flowmaster 40 installed.
(http://www.mjepps.com/xterra/2013-02-08%2017.11.20.jpg)

PML

Rear jacked up, with spare removed.
(http://www.clubxterra.org/forums/picture.php?albumid=1476&pictureid=5791)

Rear shackles installed.
(http://www.mjepps.com/xterra/2013-02-09%2007.57.04.jpg)

45 degree angle worked out damn near perfect for me.
(http://www.mjepps.com/xterra/2013-02-09%2009.18.32.jpg)

Parts removed.
(http://www.mjepps.com/xterra/2013-02-09%2010.17.06.jpg)

Here's how she sits as of now.
(http://www.mjepps.com/xterra/2013-02-09%2010.12.24.jpg)
Title: Re: Re: 04 XE 2WD Build Log
Post by: Rosie on February 10, 2013, 05:14:42 PM
Welcome, not many other first gens around! Think your picture links are faulty though.
Title: Re: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 10, 2013, 05:21:13 PM
Welcome, not many other first gens around! Think your picture links are faulty though.

Thanks.  They show up for me, but I did use the links  from clubxterra.org where I previously posted this.  Can I upload pics to this site?
Title: Re: 04 XE 2WD Build Log
Post by: Hammer (Avi) on February 10, 2013, 05:54:32 PM

Thanks.  They show up for me, but I did use the links  from clubxterra.org where I previously posted this.  Can I upload pics to this site?

No, like most forums u need an embedded image link, ["img]http://www.yourphotos.com[/img"]

I use picasa for mine.  
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 10, 2013, 08:04:28 PM
Yeah that's what I did.

I put the following inside the image tags:

http://www.clubxterra.org/forums/picture.php?albumid=1476&pictureid=5802
Title: Re: 04 XE 2WD Build Log
Post by: Hammer (Avi) on February 10, 2013, 08:36:26 PM
when i click that link i get a blank page.  It may be that you have to be logged in to view that image. 
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 10, 2013, 08:42:04 PM
Guess I'll have to post these up somewhere public.
Title: Re: 04 XE 2WD Build Log
Post by: 11Pro4X on February 10, 2013, 08:55:16 PM
pics work for me!
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 10, 2013, 09:41:32 PM
Thanks. I double checked my clubxterra album and its set to public.
Title: Re: 04 XE 2WD Build Log
Post by: Brute on February 19, 2013, 01:04:57 AM
Yeahhhh 2wd!!!! 4wd is for people that like taking the easy way out  ;D Might just be me, but i cannot see your photos either.
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 19, 2013, 09:55:02 AM
Updated the pic links, hopefully they work better.
Title: Re: 04 XE 2WD Build Log
Post by: Rev on February 19, 2013, 11:35:08 AM
Looking good! ;D

I do believe that albums on the CX site are limited viewing to CX members. So those of us who are signed up as members and have that "remember me" box checked could view the albums but not others. At least that makes sense to me lol.

The PML came out really well, now all you need are some aggressive tires and you can go just about anywhere ;D
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 19, 2013, 11:44:45 AM
Thanks Rev!

This weekend I though in a new cheap radio because I wanted an aux and usb port for playing mp3s.
(http://www.mjepps.com/xterra/2013-02-16%2011.07.58.jpg)

I also installed some fog lights on the bull bar but haven't wired them up yet.
(http://www.mjepps.com/xterra/2013-02-18%2016.22.33.jpg)
Title: Re: 04 XE 2WD Build Log
Post by: Rev on February 19, 2013, 11:47:14 AM
That radio is so on my to do list ;D

Lookin good!
Title: Re: 04 XE 2WD Build Log
Post by: Hammer (Avi) on February 19, 2013, 06:38:12 PM
Looking good.  Hope to see you at the next event.   
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 20, 2013, 09:40:00 AM
Got my hardware in for a 2" body lift.  Kinda scared to tackle that one just yet. LOL. 
Title: Re: 04 XE 2WD Build Log
Post by: Rev on February 20, 2013, 11:43:06 AM
2", go for it! I hear it's at 3" that you run into some additional worries like length of stuff. But 2" should be pretty straight forward, just follow a good guide and watch the clearance of components while lifting stuff up and you should be golden ;D
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 21, 2013, 08:30:01 AM
Yeah I've read so much on it that I feel like I could do it without reference right now.  All I need now is a weekend where my wife is busy with the kids. LOL.  I have 2 toddlers and 1 infant so getting alone time is kinda hard around my house. 

I did get my best mod yet though and just installed it.  Thanks Avi!
(http://www.mjepps.com/xterra/2013-02-20%2016.17.11.jpg)
Title: Re: 04 XE 2WD Build Log
Post by: Hammer (Avi) on February 23, 2013, 10:33:14 PM
No problem, glad you got it in a timely fashion.  Looks great!
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 25, 2013, 08:06:08 AM
Wired up my cheap fog lights this weekend.
(http://www.mjepps.com/xterra/2013-02-23%2018.16.46.jpg)

Removed the step rails and mud flaps too.
(http://www.mjepps.com/xterra/2013-02-24%2010.37.33.jpg)
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 25, 2013, 08:16:40 AM
Alexandra and Aiden taking a break from playing in the back while I remove the step rails :)
(http://www.mjepps.com/xterra/2013-01-21%2015.55.01.jpg)
Title: Re: 04 XE 2WD Build Log
Post by: Rev on February 25, 2013, 09:33:47 AM
Lights look pretty good. I like a deep yellow on the fogs. ;D

Lookin good! Hope you have a chance to install that BL soon.
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 27, 2013, 10:04:26 PM
Another easy way to carry the mountain bike.
(http://www.mjepps.com/xterra/CAM00514.jpg)
(http://www.mjepps.com/xterra/CAM00515.jpg)
Title: Re: 04 XE 2WD Build Log
Post by: Rev on February 28, 2013, 04:20:18 PM
I love Home Depot mods ;D
Title: Re: 04 XE 2WD Build Log
Post by: mjepps72 on February 28, 2013, 05:04:47 PM
Yep, piece of wood and some bolts. 
Title: Re: 04 XE 2WD Build Log
Post by: Hammer (Avi) on April 25, 2013, 08:10:40 PM
where did you get that front end clip, not a bad way to set it up. 
Title: Re: Re: 04 XE 2WD Build Log
Post by: mjepps72 on April 25, 2013, 09:23:15 PM
Amazon has them for $17.

Sent from my LG-P870 using Tapatalk 2