Arizona All Nissan Club

General Discussion => Welcome New Members => Topic started by: pinchel (Rob) on May 13, 2013, 06:33:00 PM

Title: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on May 13, 2013, 06:33:00 PM
It's getting hot. My family and plan to head for the northern parts and do some more off roading in our more or less stock Xterra.
I have yet to really use it for much other than a DD since we bought it new off the lot. So we're looking for suggestions and help with maintaining it and upgrading it's capabilities.

Hope to meet some of you soon!

Rob aka pinchel

***added some pictures
(http://www.azmazda3.com/forum/MGalleryItem.php?id=799)

(http://www.azmazda3.com/forum/MGalleryItem.php?id=798)

(http://www.azmazda3.com/forum/MGalleryItem.php?id=797)

(http://www.azmazda3.com/forum/MGalleryItem.php?id=800)
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: 11Pro4X on May 14, 2013, 09:48:47 AM
Welcome to AZXC!

There are lots of mods and upgrades to do! 
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: PitSnipe (Kyle) on May 14, 2013, 11:03:23 AM
Welcome to the club. Lots of browsing ahead of you in the site. Good luck. Looking forward to some pics of your X.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on May 14, 2013, 02:14:33 PM
Welcome to the club, let me or one of the other moderators know if you need help with anything :)
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on May 15, 2013, 01:59:13 PM
Welcome to the club, let me or one of the other moderators know if you need help with anything :)

I need plenty 'o help.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on May 15, 2013, 02:00:32 PM
Welcome to AZXC!

There are lots of mods and upgrades to do! 

I realize. I was on the xterra.org for awhile but mostly just trolling and maintenance stuff...which I am still working on.

Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on May 15, 2013, 07:21:27 PM
Welcome to the club, let me or one of the other moderators know if you need help with anything :)

I need plenty 'o help.
We have mod days all the time, let us know what you need help with and we will get a day planned. 
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on June 17, 2013, 04:55:00 PM
Welcome to the club, let me or one of the other moderators know if you need help with anything :)

I need plenty 'o help.
We have mod days all the time, let us know what you need help with and we will get a day planned. 

The list is never ending, but I'd like to start with as much poor man stuff as possible. :)
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on June 18, 2013, 05:51:20 PM
I'm not too familiar with the pml on the 1st gen, I'm a second gen guy.  But I know we have some people on this forum that can help you, and my garage is always available to you, preferably when it isnt 110 outside. 
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Slapshotking09 on June 18, 2013, 08:50:34 PM
Get ready for the mod bug to hit.  ;D
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on June 20, 2013, 07:36:42 PM
I was primarily focused on the other vehicle, but that stopped when we moved back to Arizona as it isn't much fun as going to the woods.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 29, 2013, 12:46:48 PM
I got our AZXC decal in the mail just gotta put it on.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: remo1991(Brent) on July 29, 2013, 01:26:37 PM
that's 10hp more as soon as you put it on.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 29, 2013, 06:10:35 PM
Decal added! I just gotta get a picture on here. I had to take one of the wife's decals off though. Lol
Also, the wife just got home and told me the Xterra did not crank when she went to start it this afternoon. Not a good thing to hear just before going on a long road trip.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: DBAX on July 29, 2013, 08:26:29 PM
Speaking from experience, that's a good thing. It sure beats your broke X on the side of the road, in that 110* heat, stuffed with, I dunno'? Camping gear, coolers, a dog, kids? Of course the wife.. She's in there reminding you it's hot outside and the X is broken on the way to your big offroad weekend thing. Yeah. Better now than then..
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on July 29, 2013, 08:42:14 PM
probably a bad battery, they always seem to get you in AZ.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 29, 2013, 09:16:51 PM
probably a bad battery, they always seem to get you in AZ.

It better not be, we just replaced not even 2 months ago. I know we have a/c issues which could be related to other stuff. I don't need a/c. She runs it all day with the a/c on high which is killing it I'm sure. We really need to get her into a different daily driver, but can't afford it right now.

I changed the oil & filter. Topped the fluids and everything looked normal, sort of. I know the bottom was gummed up from a leak we fixed months ago but there seemed to be something else sludging on the  bottom and it seems to be coming from the top somewhere.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on July 29, 2013, 09:53:24 PM
i run my a/c on high all day, that wouldn't cause an issue.  I would bet it is the battery, but could be a starter motor or alternator as well.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Jack5885 on July 29, 2013, 10:28:37 PM
Batteries don't like AZ heat, thats for sure. Its the easiest thing to check, so might as well start there even if its fairly new.

And if its only 2 months old and it went out, I'm sure the full replacement warranty is still good.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 29, 2013, 10:39:23 PM
We've just had the starter replaced, and battery. Separate issues but both recent. As far as the a/c, that is something  that is an issue in the summer only. In the colder months, no issues. It's just in the heat the Xterra has issues while running the a/c, and if we don't run it, everything is fine.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on July 30, 2013, 01:41:31 AM
As long as your cooling system is working properly, you shouldn't have an issue.  If the truck starts to heat up it automatically shuts down the AC compressor.  If you are having issues with your truck while the AC is running, it is probably something else causing your trouble. 
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 31, 2013, 01:52:18 PM
(http://www.azmazda3.com/forum/MGalleryItem.php?id=831)

The pink butterfly is to support my friends daughter Katie - http://vanforkatie.com/ (http://vanforkatie.com/)
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: Hammer (Avi) on July 31, 2013, 05:40:15 PM
Looking good :)
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: PitSnipe (Kyle) on July 31, 2013, 06:06:58 PM
Nice. Why don't you have a build thread?
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on July 31, 2013, 06:19:31 PM
Nice. Why don't you have a build thread?

I figured this would suffice. :D
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: AZdesertX on August 02, 2013, 03:15:33 PM
i know you lol
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on August 11, 2013, 09:19:58 AM
i know you lol

Yes I know! That's what I said... lol Now we have something else in common but your vehicle is way cooler than mine as usual.
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: WHPIVxterra on August 11, 2013, 07:51:21 PM
Hey man! I'm new to the Tempe area but I did all my mods up in New England on my 1st gen.  Hit me up if you need an extra set of hands and some experience.  I am currently unemployed and bored as hell right now so getting out of the house would be a god send
Title: Re: It's me Pinchel! '04 Xterra XE V6 in South PHX/Tempe/Tukee area
Post by: pinchel (Rob) on August 12, 2013, 07:16:09 AM
Hey man! I'm new to the Tempe area but I did all my mods up in New England on my 1st gen.  Hit me up if you need an extra set of hands and some experience.  I am currently unemployed and bored as hell right now so getting out of the house would be a god send

Sounds good! Right now it's figuring out the starting issue for which I have started a separate new thread in the Garage section.