Arizona All Nissan Club

General Discussion => How To / DIY => Topic started by: xterra06 on May 20, 2013, 09:27:08 AM

Title: Xterra RF radio
Post by: xterra06 on May 20, 2013, 09:27:08 AM
Ok so i went to install my new subs and amp, but now for some weird reason the radio comes on but i have no sound at all coming from the speakers... I have double and triple checked fuses and everything... does anyone have a wire diagram of the back of the radio harnesses, and also the amp wiring diagram not sure what the heck is going on... i do get a little thud from the sub when i turn on the car... so any input would be amazing!!!
Title: Re: Xterra RF radio
Post by: Slapshotking09 on May 20, 2013, 11:07:09 AM
1. Amp to Battery - Run a 4 gauge wire from the battery, put an in-line fuse in it near the battery. Run the wire through the firewall, and in under the door trims (usally best spot) along the inside of the car to the back. You may have to remove your backseat to feed the wire in your trunk.

2. Amp to Ground - Short piece of 4 gauge ground wire, and attach it SECURELY to the metal of your trunk. Be sure to scrape away all paint before the doing it. Best thing to do is but a nut and bolt through the ground.

3. Remote Wire - run the remote wire (blue wire) from the HU to the amp. Run under the door trims aswell

4. RCA's - run rca wires from your HU to your amp the same way you would for your power and remote wire. HOWEVER, be sure to run your RCA's and remote wire on opposite side of the car as you ran your power. This elimates unwanted noise.

Also make sure u turn the sub on through the rf radio settings. Just because you connect it doesn't mean it's on.
Title: Re: Xterra RF radio
Post by: xterra06 on May 20, 2013, 02:21:38 PM
Oh what i meant was through the factory Rockford amp no sound... the radio comes on but no sound from the amp... i have the other amp completely disconnected and still nothing... so i need the diagram for what pins on the factory amp do what and same for the factory deck... i want to rule out all things before i run to the dealership... so i wanted to trace wires and everything. I was thinking maybe i had 2 wires touching when i was wiring things up cause the fuse did snap but all the fuses are good now and i know the amp has to be getting some power cause the sub makes the little thud when the car is started... I did notice that the one power wire i was using no longer has power going to it... so idk, i must have done something...

I need the diagrams for the radio and the sub and the amp... just so i can trace the wires and maybe i fried the deck wires or the amp... idk i just need help!
Title: Re: Xterra RF radio
Post by: xterra06 on May 21, 2013, 08:17:46 AM
Amp is shot, so now to find an oem amp to put in its place...