Arizona All Nissan Club

General Discussion => Open Discussions => Topic started by: xterra06 on August 29, 2013, 04:32:32 PM

Title: Truck problems!!
Post by: xterra06 on August 29, 2013, 04:32:32 PM
Ok so for the last 3 days i have been having so many issues with the truck.... I had p0420, p0430, p0183, p0300, and another code but i dont remember...
So yesterday replaced the 2 upstream sensors that i was told may fix it and it got rid of the p0420 and p0183 code... now i still have p0300 and p0430.... today i replaced all the plugs with NGK Laser Platinum and drove it around a little and i STILL have the p0300, and p0430...  so now its down to replace the last 2 O2 sensors and the Catalytic Converters.... and pray that fixes the issue.... please let me know if anyone has suggestions....
Title: Re: Truck problems!!
Post by: PitSnipe (Kyle) on August 29, 2013, 05:21:31 PM
P0300 is Multiple Cylinder Misfire.
P0430 is Three Way Catalyst Function
P0430 is gonna be O2 and/or cat problem.
Title: Re: Truck problems!!
Post by: xterra06 on August 29, 2013, 05:34:58 PM
ya i figured i will go to the muffler shop and get both cats replaced and see if that helps and if not i will grab the o2 sensors downstream and do that and as for the p0300... im so lost its unreal... i hope its not the coils...
Title: Re: Truck problems!!
Post by: xterra06 on August 29, 2013, 05:37:07 PM
Truck runs well.... except over like 2500-3000+ RPM.... then its slower and doesnt have any guts...   i have had a few people telling me that it could be the computer throwing everything off since the p0430... but doesnt seem likely...  i just need my truck back... dont feel safe driving like it is...
Title: Re: Truck problems!!
Post by: PitSnipe (Kyle) on August 29, 2013, 05:42:15 PM
Clear the codes and see how long It takes to reset.
Title: Re: Truck problems!!
Post by: xterra06 on August 29, 2013, 05:48:59 PM
few min of driving
Title: Re: Truck problems!!
Post by: xterra06 on August 29, 2013, 05:50:13 PM
i mean kyle, is it possible that a clogged cat or bad o2 cause an issue like this??? I mean if its a possibility that will be my next route...
Title: Re: Truck problems!!
Post by: PitSnipe (Kyle) on August 29, 2013, 06:06:07 PM
Fix the cats and O2s first. A misfire is a lot easier to diag when its the only problem.
Title: Re: Truck problems!!
Post by: xterra06 on August 29, 2013, 06:11:11 PM
ok sounds like a plan then...
Title: Re: Truck problems!!
Post by: HuskerNation on September 10, 2013, 08:23:49 PM
How did your repairs work out for you?  I run into that a lot and know your cure,'message me if you have questions.
Aaron Schulte
HuskerNation
Title: Re: Truck problems!!
Post by: xterra06 on September 20, 2013, 05:07:05 PM
So after 2 New cats and 2 front o2 and bypassed the secondary cats, (yes our truck has 4 f**king cats...) and new magnaflow muffler now i have a p420 and its for the rear 2 o2 sensors and the truck runs like a champ minus the SES light, once i get the 300 for 2 o2 sensors that should fix that and it will be all great.