collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2019 AZXC Supporting Member just Click the Donate button.

* Calendar

January 2019
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 [18] 19
20 21 22 23 24 25 26
27 28 29 30 31

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 13
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • PitSnipe (Kyle): I could use some new ones
    January 14, 2019, 05:06:24 PM
  • pinchel (Rob): not me
    January 14, 2019, 05:03:26 PM
  • REXTERRA: Anyone have black second gen headlights that they would want to trade for Chrome or sell outright
    January 13, 2019, 11:53:18 AM
  • pinchel (Rob): Updating the Supporting Members list...
    January 10, 2019, 05:27:32 PM
  • Thupertrooper (Victor): 2019 Kick off Run Date Poll  [link]
    January 03, 2019, 09:59:33 PM
  • Thupertrooper (Victor): 2019 Kick off Run planning [link]
    January 03, 2019, 09:52:57 PM
  • PitSnipe (Kyle): Nope. I have those as back ups for mine.
    December 27, 2018, 10:06:30 PM
  • AZGeorge: Are those my old Bilstien's?
    December 24, 2018, 06:52:55 PM
  • REXTERRA: Kyle shoot me a text, 480-326-9677
    December 18, 2018, 09:40:55 AM
  • PitSnipe (Kyle): I have a set of front bilstien 4600s. The ones that come on the Pro4X
    December 17, 2018, 09:48:54 AM
  • pinchel (Rob): nope
    December 16, 2018, 08:34:00 AM
  • REXTERRA: Anyone have any extra front struts and spacers, my struts are shot
    December 16, 2018, 01:04:35 AM
  • pinchel (Rob): For a limited time, for current Supporting Members all swag is available at cost. Message me for details.
    December 08, 2018, 10:35:26 AM
  • pinchel (Rob): We you going to the static page or the forum?
    December 08, 2018, 10:22:46 AM
  • 14Frontier: earliar today my phone was warning the coonextion was not secure when entering my password
    December 05, 2018, 01:30:40 PM
  • PitSnipe (Kyle): November ToTM Poll is up. Time to vote
    December 01, 2018, 12:44:59 PM
  • pinchel (Rob): It's working....
    November 28, 2018, 04:16:13 PM
  • PitSnipe (Kyle): are we fixed yet?
    November 28, 2018, 04:09:15 PM
  • pinchel (Rob): it might have been your phone that broke it
    November 26, 2018, 07:00:33 PM
  • theonepathfinder: Thought it was my phone acting up again lol
    November 26, 2018, 06:58:58 PM
GoTo RockAuto Vinyltats Nissan Accessories & Parts at CARiD.com
Combat Wipes The Scrubblade Advantage
CVT Tents and Awnings Nissan Accessories & Parts at CARiD.com Nissan Accessories & Parts at CARiD.com

Author Topic: Xterra issues  (Read 2110 times)

0 Members and 1 Guest are viewing this topic.

TeguTerra

  • Guest
Xterra issues
« on: June 17, 2015, 06:48:55 AM »
So the X has started randomly shutting off going down the road,  researched and everything was leaning towards camshaft position sensor so I replaced that.   Still doing it, the service engine soon light,  vdc off light and slip light all come on.   It is also lurching sometimes when slowly coming to a stop.   Did some more research and found something saying if you do a lift and bigger tires it can throw the steering column angle sensor off which in turn confuses the main board that collects all that data so it then errors and shuts you down,  has anyone else had this issue and does it sound legit? 

Sent from my SAMSUNG-SM-G900A using Tapatalk

Offline Xtracrispy

  • Noob
  • *
  • Posts: 28
Re: Xterra issues
« Reply #1 on: June 17, 2015, 07:38:59 AM »
I have heard of the slip and vdc light coming on, but not shutting down. IF you have VDC and your steering wheel is not aligned it thinks the wheel is turned, but you are going straight and can get confused. I know the IPDM relay has a recall that I believe causes shutdown, but not sure about the other lights.

You say the SES (service engine) light is on, do you have access to an OBD scanner?

TeguTerra

  • Guest
Re: Xterra issues
« Reply #2 on: June 17, 2015, 07:53:06 AM »
I checked the codes and it was C1130/P0340/U1000
The P0340 is that cam position sensor and then it was looking like the others where caused by the sensor but still a no go.   I may call the stealer ship and see what they have in mind. 

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1844
  • Gender: Male
Re: Xterra issues
« Reply #3 on: June 17, 2015, 08:37:38 AM »
If it is an 05-06 the epdms will cause that
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

TeguTerra

  • Guest
Re: Xterra issues
« Reply #4 on: June 17, 2015, 09:33:27 AM »


Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re:
« Reply #5 on: June 17, 2015, 09:34:17 AM »
I did this and everything checked out for the IPDM-ER,  it's a 07

Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re:
« Reply #6 on: June 17, 2015, 03:35:08 PM »
So the vdc off light and slip light shut off after awhile so went and had the code pulled again.  P0340 which is cam position sensor bank 1  which is on passenger side.  Got the part and will replace once the engine bay cools off and cross figures it fixes it :) 

Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re: Xterra issues
« Reply #7 on: June 17, 2015, 07:02:59 PM »
That sensor is now switched and everything seems to be running good,  and let me say that was a fun one to get out. 

Offline Slapshotking09

  • Board of Directors
  • Hero Member
  • *****
  • Posts: 761
  • Gender: Male
Re: Xterra issues
« Reply #8 on: June 17, 2015, 08:06:25 PM »
I did this about a month ago and it sucked! Had to lay on top of the engine basically. Good to see you're up and running again

Offline AZ-Ted

  • Supporting Member
  • Hero Member
  • *****
  • Posts: 849
  • Gender: Male
    • AZ-Ted's YouTube Site
Re:
« Reply #9 on: June 17, 2015, 08:31:20 PM »
So the vdc off light and slip light shut off after awhile so went and had the code pulled again.  P0340 which is cam position sensor bank 1  which is on passenger side....

Hopefully, the other two codes don't come back.  The U1000, in particular, can be troublesome.  I haven't had to deal with it, but both Conundrum (Adam) and Onix (Wally) had to eventually sell their trucks because of long-term issues with U1000.


That sensor is now switched and everything seems to be running good,  and let me say that was a fun one to get out. 

Awesome!  Hot day for it, though.
2006 XOR; Titan Swapped; Fully Shrocked, etc., etc.
2013 Titan Pro4X:  A.R.E. "Z" series truck cap

TeguTerra

  • Guest
Re: Xterra issues
« Reply #10 on: June 17, 2015, 08:42:35 PM »
@Ted. Yeah,  cross my fingers and hope it's good.  I read that the U1000 was caused by the cam sensor not sending info so would cause that and the C1130.  I hope they stay away now.   @Vince, definitely a lot harder to do then the bank 2 drivers side one,  don't know if I could bend my arm like that again,  lol.