collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2018 AZXC Supporting Member just Click the Donate button.

* Calendar

February 2018
Sun Mon Tue Wed Thu Fri Sat
1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
[25] 26 27 28

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 13
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • Thupertrooper (Victor): Mod Day still under way
    Yesterday at 01:16:40 PM
  • pinchel (Rob): We'll have our AZXC swag for sale, and for those who show up special Mod Day prices!
    Yesterday at 07:10:12 AM
  • Thupertrooper (Victor): PM for Directions. Its in Mesa
    February 23, 2018, 10:15:13 AM
  • Thupertrooper (Victor): Mod Day tomorrow. [link]
    February 23, 2018, 10:15:00 AM
  • pinchel (Rob): Sooo many options....you should checkout RPMFAB if you have the dough.
    February 10, 2018, 09:01:57 AM
  • Thupertrooper (Victor): Link to my flickr account. [link]
    February 09, 2018, 10:34:29 AM
  • ShakenNotStirred (Cooper): WTB: Aftermarket skid plates for 2nd gen Xterra. Lmk what you have available.
    February 09, 2018, 09:22:05 AM
  • Rubio480: Victor has some in his flicker
    February 08, 2018, 10:41:42 PM
  • pinchel (Rob): Did you not post yours?
    February 07, 2018, 05:49:58 PM
  • FieldDay: Where are all the kickoff run pictures??
    February 06, 2018, 12:12:33 PM
  • Rear Axle Seal: I am thinking working on doing a D21 Hardbody theme for my Titan.  I have already gone deep and cut three holes in my hood for the actual vents from the 87-91.  Also picked up Nissan 4X4 emblem from 86-89 Hardbodies.  Any other ideas out there on how to tie in the design elements?
    February 05, 2018, 11:41:55 AM
  • PitSnipe (Kyle): I saw him at the lake the night before the kickoff run. He's been very busy lately.
    February 03, 2018, 05:00:34 PM
  • remo1991(Brent): Man haven't seen Avi on here in long time
    February 03, 2018, 10:33:15 AM
  • pinchel (Rob): I wish I could go...got family visiting
    February 02, 2018, 06:19:58 PM
  • ShockBlue_Scott: I know it is late notice but anyone interested in some shooting tomorrow in the 4 Peaks area?
    February 01, 2018, 06:31:50 PM
  • pinchel (Rob): oooohhhh
    January 31, 2018, 07:39:19 PM
  • Rubio480: I have your walkie I believe
    January 29, 2018, 08:41:19 PM
  • pinchel (Rob): 8)
    January 29, 2018, 04:05:59 PM
  • ShakenNotStirred (Cooper): Whats up Rubio!? Nice meeting you guys this weekend!
    January 29, 2018, 03:00:15 PM
  • Rubio480: Coooooooper
    January 28, 2018, 04:08:39 PM

Author Topic: Xterra issues  (Read 1533 times)

0 Members and 1 Guest are viewing this topic.

TeguTerra

  • Guest
Xterra issues
« on: June 17, 2015, 06:48:55 AM »
So the X has started randomly shutting off going down the road,  researched and everything was leaning towards camshaft position sensor so I replaced that.   Still doing it, the service engine soon light,  vdc off light and slip light all come on.   It is also lurching sometimes when slowly coming to a stop.   Did some more research and found something saying if you do a lift and bigger tires it can throw the steering column angle sensor off which in turn confuses the main board that collects all that data so it then errors and shuts you down,  has anyone else had this issue and does it sound legit? 

Sent from my SAMSUNG-SM-G900A using Tapatalk

Offline Xtracrispy

  • Noob
  • *
  • Posts: 28
Re: Xterra issues
« Reply #1 on: June 17, 2015, 07:38:59 AM »
I have heard of the slip and vdc light coming on, but not shutting down. IF you have VDC and your steering wheel is not aligned it thinks the wheel is turned, but you are going straight and can get confused. I know the IPDM relay has a recall that I believe causes shutdown, but not sure about the other lights.

You say the SES (service engine) light is on, do you have access to an OBD scanner?

TeguTerra

  • Guest
Re: Xterra issues
« Reply #2 on: June 17, 2015, 07:53:06 AM »
I checked the codes and it was C1130/P0340/U1000
The P0340 is that cam position sensor and then it was looking like the others where caused by the sensor but still a no go.   I may call the stealer ship and see what they have in mind. 

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1844
  • Gender: Male
Re: Xterra issues
« Reply #3 on: June 17, 2015, 08:37:38 AM »
If it is an 05-06 the epdms will cause that
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

TeguTerra

  • Guest
Re: Xterra issues
« Reply #4 on: June 17, 2015, 09:33:27 AM »


Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re:
« Reply #5 on: June 17, 2015, 09:34:17 AM »
I did this and everything checked out for the IPDM-ER,  it's a 07

Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re:
« Reply #6 on: June 17, 2015, 03:35:08 PM »
So the vdc off light and slip light shut off after awhile so went and had the code pulled again.  P0340 which is cam position sensor bank 1  which is on passenger side.  Got the part and will replace once the engine bay cools off and cross figures it fixes it :) 

Sent from my SAMSUNG-SM-G900A using Tapatalk

TeguTerra

  • Guest
Re: Xterra issues
« Reply #7 on: June 17, 2015, 07:02:59 PM »
That sensor is now switched and everything seems to be running good,  and let me say that was a fun one to get out. 

Offline Slapshotking09

  • Board of Directors
  • Hero Member
  • *****
  • Posts: 760
  • Gender: Male
Re: Xterra issues
« Reply #8 on: June 17, 2015, 08:06:25 PM »
I did this about a month ago and it sucked! Had to lay on top of the engine basically. Good to see you're up and running again

Offline AZ-Ted

  • Hero Member
  • *****
  • Posts: 839
  • Gender: Male
    • AZ-Ted's YouTube Site
Re:
« Reply #9 on: June 17, 2015, 08:31:20 PM »
So the vdc off light and slip light shut off after awhile so went and had the code pulled again.  P0340 which is cam position sensor bank 1  which is on passenger side....

Hopefully, the other two codes don't come back.  The U1000, in particular, can be troublesome.  I haven't had to deal with it, but both Conundrum (Adam) and Onix (Wally) had to eventually sell their trucks because of long-term issues with U1000.


That sensor is now switched and everything seems to be running good,  and let me say that was a fun one to get out. 

Awesome!  Hot day for it, though.
2006 XOR; Titan Swapped; Fully Shrocked, etc., etc.
2013 Titan Pro4X:  A.R.E. "Z" series truck cap

TeguTerra

  • Guest
Re: Xterra issues
« Reply #10 on: June 17, 2015, 08:42:35 PM »
@Ted. Yeah,  cross my fingers and hope it's good.  I read that the U1000 was caused by the cam sensor not sending info so would cause that and the C1130.  I hope they stay away now.   @Vince, definitely a lot harder to do then the bank 2 drivers side one,  don't know if I could bend my arm like that again,  lol.