collapse

Donate

Become a 2017/18 AZXC Supporting Member just Click the Donate button.

* Calendar

October 2017
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 [18] 19 20 21
22 23 24 25 26 27 28
29 30 31

No calendar events were found.

* Newest Member

* Who's Online

  • Dot Guests: 21
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • PitSnipe (Kyle): I mounted two yesterday and the other three will arrive today
    Today at 11:01:10 AM
  • remo1991(Brent): pictures
    Today at 09:38:53 AM
  • PitSnipe (Kyle): These mud terrains look awesome
    Today at 09:07:24 AM
  • PitSnipe (Kyle): I got a good deal on the Mastercraft Courser MXT from work. I blew a tire and slided another at CANVAZ. My duratracs were getting low already so I jumped on the new tires. I stayed with the 285/75R16
    Today at 09:06:53 AM
  • DBAX: 5 new tires is always fun. What'd you go w/ Kyle?
    Today at 07:52:29 AM
  • XTiki: I'll clean the tent out next weekend.  ha
    Yesterday at 09:20:48 PM
  • PitSnipe (Kyle): I got 5 new tires today
    Yesterday at 05:47:13 PM
  • pinchel (Rob): Did you get it fixed?
    Yesterday at 04:32:36 PM
  • Hammer (Avi): It was a great weekend, we decided to stop in flag instead of going home, but now its back to work and real life
    Yesterday at 02:24:37 AM
  • pinchel (Rob): Coffee & Crawlers is every 2nd Saturday.
    October 16, 2017, 03:31:12 PM
  • PitSnipe (Kyle): Just finished unloading my X. Still smells like smoke.
    October 16, 2017, 10:05:42 AM
  • Thupertrooper (Victor): CANVAZ was a blast still haven't fully unloaded the truck.
    October 16, 2017, 08:47:00 AM
  • PitSnipe (Kyle): Got homenfrom CANVAZ at 730pm. Was so tired we all took a shower and went to bed. Now to unpack the X and clean it up. It was a great weekend. Thanks to all that attended. We didn't get a final rig count but it was somewhere in the ballpark of 26.
    October 16, 2017, 07:42:12 AM
  • Forrest: How often does coffee and crawlers happen?
    October 13, 2017, 04:00:15 PM
  • pinchel (Rob): First day of CANVAZ 2017!
    October 13, 2017, 06:41:09 AM
  • Thupertrooper (Victor): I was trying to get everything ready since Wednesday but couldnt get my rig aligned so friday morning it is for me. Ill post my actual departure to meet up with some of you guys
    October 12, 2017, 06:53:36 AM
  • ShockBlue_Scott: Well I am now the owner of a 2nd Gen Xterra.
    October 12, 2017, 06:48:48 AM
  • pinchel (Rob): Depends though, I'm waiting on some details before I can set a final departing time.
    October 11, 2017, 07:27:21 PM
  • pinchel (Rob): I plan to drive up no later than Friday morning.
    October 11, 2017, 07:26:49 PM
  • XTiki: Want to make Secret Pass run at noon.
    October 11, 2017, 07:22:07 PM

Author Topic: Need Help my X is making an odd sound when turning  (Read 1129 times)

0 Members and 1 Guest are viewing this topic.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Need Help my X is making an odd sound when turning
« on: March 31, 2016, 12:03:38 PM »
Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well
« Last Edit: April 21, 2016, 04:30:03 PM by USAF2W1 »
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 737
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Offline XterrasNameIsMolly (Justin)

  • Full Member
  • ***
  • Posts: 141
  • Gender: Male

Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.
ToTM February 2016, May 2016

Nisstec Extended Travel Lift ~3 inch suspension lift, Sasa Sliders, Snorkel

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Will do


Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.

Thanks for the help I'll give that a try tomorrow and see. My sway bar is still on i only added the spacer and the AAL with no other modifications.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Jo-BOB

  • Sr. Member
  • ****
  • Posts: 328
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.
Thanks for the offer I was thinking about messing around with the truck this Sunday. I live on the North East side of town Catalina Hwy and Tanque Verde.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #6 on: April 21, 2016, 04:36:42 PM »
So I spend 3 hours checking for anything obvious or loose hardware with no luck. I'm at the point where i don't care about the noises i just want to make sure my trucks not going to leave me stranded because that sound ended up being something serious. heres a short clip i made the sound. You can hear it 14 seconds in and at 23 seconds.
https://youtu.be/mlPw54Zda04
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 737
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #7 on: April 21, 2016, 06:05:44 PM »
It does sounds like the spring being twisted and then it lets go.
Maybe send some pictures of the springs. I dont remember if there is a bushing for the top hat of the springs.

 



Copyright ©2015 Arizona Xterra Club The Nissan names, logos and slogans are registered trademarks of Nissan Motor Co. Ltd and is no way affiliated with this site. All posts are the property of the posters and are not the responsibility of the Arizona Xterra Club, it's affiliates, web hosts or associated companies.