collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2019 AZXC Supporting Member just Click the Donate button.

* Calendar

December 2018
Sun Mon Tue Wed Thu Fri Sat
1
2 3 4 5 6 7 8
9 10 11 12 13 14 [15]
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31

No calendar events were found.

Upcoming Events

Sorry! There are no calendar events available at the moment.

* Newest Member

* Who's Online

  • Dot Guests: 33
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • pinchel (Rob): For a limited time, for current Supporting Members all swag is available at cost. Message me for details.
    December 08, 2018, 10:35:26 AM
  • pinchel (Rob): We you going to the static page or the forum?
    December 08, 2018, 10:22:46 AM
  • 14Frontier: earliar today my phone was warning the coonextion was not secure when entering my password
    December 05, 2018, 01:30:40 PM
  • PitSnipe (Kyle): November ToTM Poll is up. Time to vote
    December 01, 2018, 12:44:59 PM
  • pinchel (Rob): It's working....
    November 28, 2018, 04:16:13 PM
  • PitSnipe (Kyle): are we fixed yet?
    November 28, 2018, 04:09:15 PM
  • pinchel (Rob): it might have been your phone that broke it
    November 26, 2018, 07:00:33 PM
  • theonepathfinder: Thought it was my phone acting up again lol
    November 26, 2018, 06:58:58 PM
  • pinchel (Rob): It's not fixed. Yet.
    November 26, 2018, 06:58:15 PM
  • Thupertrooper (Victor): Thank you Rob for addressing this.
    November 26, 2018, 06:56:53 PM
  • pinchel (Rob): Site is up, but I have not identified the cause so I ask you not post anything as it will get lost. Messages are fine.
    November 26, 2018, 06:46:14 PM
  • pinchel (Rob): Happy Thanksgiving!
    November 22, 2018, 10:51:31 AM
  • pinchel (Rob): :o
    November 18, 2018, 09:14:49 AM
  • pinchel (Rob): Happy Veterans Day!
    November 11, 2018, 09:51:09 AM
  • PitSnipe (Kyle): Its Mod Day time
    November 10, 2018, 07:21:11 AM
  • pinchel (Rob): 8)
    November 05, 2018, 04:44:59 PM
  • Nissankid83: Hey is anyone intrested in going to the street legal drag races? Kinda want to take the new titan out.. heres the link [link]
    November 04, 2018, 04:36:19 PM
  • Desertrunner2169: Who is all coming today to the flag run
    November 04, 2018, 07:38:51 AM
  • Thupertrooper (Victor): November 10th Mod Day
    October 29, 2018, 09:59:58 PM
  • Thupertrooper (Victor): November 4th Flag Run
    October 29, 2018, 09:59:47 PM
GoTo RockAuto Vinyltats Nissan Accessories & Parts at CARiD.com
Combat Wipes The Scrubblade Advantage
CVT Tents and Awnings Nissan Accessories & Parts at CARiD.com Nissan Accessories & Parts at CARiD.com

Author Topic: Need Help my X is making an odd sound when turning  (Read 2183 times)

0 Members and 1 Guest are viewing this topic.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Need Help my X is making an odd sound when turning
« on: March 31, 2016, 12:03:38 PM »
Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well
« Last Edit: April 21, 2016, 04:30:03 PM by USAF2W1 »
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 900
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Offline XterrasNameIsMolly (Justin)

  • Full Member
  • ***
  • Posts: 157
  • Gender: Male

Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.
ToTM February 2016, May 2016

Nisstec Extended Travel Lift ~3 inch suspension lift, Sasa Sliders, Snorkel

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Will do


Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.

Thanks for the help I'll give that a try tomorrow and see. My sway bar is still on i only added the spacer and the AAL with no other modifications.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Jo-BOB

  • Sr. Member
  • ****
  • Posts: 328
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.
Thanks for the offer I was thinking about messing around with the truck this Sunday. I live on the North East side of town Catalina Hwy and Tanque Verde.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #6 on: April 21, 2016, 04:36:42 PM »
So I spend 3 hours checking for anything obvious or loose hardware with no luck. I'm at the point where i don't care about the noises i just want to make sure my trucks not going to leave me stranded because that sound ended up being something serious. heres a short clip i made the sound. You can hear it 14 seconds in and at 23 seconds.
https://youtu.be/mlPw54Zda04
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 900
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #7 on: April 21, 2016, 06:05:44 PM »
It does sounds like the spring being twisted and then it lets go.
Maybe send some pictures of the springs. I dont remember if there is a bushing for the top hat of the springs.