collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2018 AZXC Supporting Member just Click the Donate button.

* Calendar

August 2018
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 [17] 18
19 20 21 22 23 24 25
26 27 28 29 30 31

No calendar events were found.

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 25
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • PitSnipe (Kyle): Hi Brent
    Yesterday at 08:50:03 AM
  • PitSnipe (Kyle): Wow, I have not heard of this issue. 15 hour job for a $50 part is nuts. Hopefully someone that knows of this issue will speak up.
    August 13, 2018, 12:42:16 PM
  • downs44: Got an 06 that just went through SMOD. Got everything replaced. Now my low oil pressure light is flickering on after the engine warms up and the truck is at idle. Doing some digging on the forums it looks like a common problem is the rear timing cover gallery gasket leaking and causes the symptoms. Looks like a 15 hour or so repair for a $50 part. Was wondering if anyone else has had this issue and any words of advise. To save some dialogue, the oil pressure sensor is about a year old and I changed the oil and filter after i noticed the light and that did not fix the issue.
    August 11, 2018, 05:31:19 PM
  • Jo-BOB: she needs both?
    August 09, 2018, 12:22:48 PM
  • PitSnipe (Kyle): Chantel does
    August 09, 2018, 09:34:21 AM
  • Jo-BOB: anyone in the group need a 2nd gen engine or transmission by chance?
    August 08, 2018, 10:37:26 PM
  • PitSnipe (Kyle): Go ahead and ask away
    August 08, 2018, 08:21:55 AM
  • downs44: I have been on thenewx quite a bit. hoping to find some local insight.
    August 08, 2018, 08:11:59 AM
  • PitSnipe (Kyle): We can do the best to help here, but try out the national site TheNewX.org
    August 08, 2018, 07:47:54 AM
  • downs44: Hey! Newbie here. I met some of you guys at the F2GC event this weekend. I was with the mountain rescue group. Did not have my X up there due to some mechanical issues. I need some input and was wondering which forum I should put my questions in.
    August 08, 2018, 07:45:12 AM
  • pinchel (Rob): Please make sure to tag and share any social media for our sponsor(s) - Combat Wipes
    August 07, 2018, 04:46:23 PM
  • Thupertrooper (Victor): Had a blast. Awesome time
    August 07, 2018, 04:23:01 PM
  • PitSnipe (Kyle): What a great weekend it was
    August 06, 2018, 10:08:14 AM
  • pinchel (Rob): Thanks everyone who made it out to Flag2GC!
    August 05, 2018, 04:25:15 PM
  • pinchel (Rob): See you all there!
    August 02, 2018, 05:42:33 AM
  • Edwin562: im thinking of doing the JP project on my 1.5 gen...
    July 31, 2018, 08:14:41 PM
  • azxtreme: I need one to powder coat red for the Jurassic Park Xterra
    July 29, 2018, 08:00:39 PM
  • azxtreme: Well I know he's out of business apparently and I know sometimes people sell their trucks or go different routes
    July 29, 2018, 08:00:06 PM
  • pinchel (Rob): extra?
    July 29, 2018, 07:48:02 PM
  • azxtreme: Anyone have an extra xoskel light cage or low Pro bar
    July 29, 2018, 07:44:36 PM
GoTo RockAuto Vinyltats Nissan Accessories & Parts at CARiD.com
Combat Wipes The Scrubblade Advantage
CVT Tents and Awnings Nissan Accessories & Parts at CARiD.com Nissan Accessories & Parts at CARiD.com

Author Topic: Need Help my X is making an odd sound when turning  (Read 1868 times)

0 Members and 1 Guest are viewing this topic.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Need Help my X is making an odd sound when turning
« on: March 31, 2016, 12:03:38 PM »
Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well
« Last Edit: April 21, 2016, 04:30:03 PM by USAF2W1 »
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Offline XterrasNameIsMolly (Justin)

  • Supporting Member
  • Full Member
  • *****
  • Posts: 157
  • Gender: Male

Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.
ToTM February 2016, May 2016

Nisstec Extended Travel Lift ~3 inch suspension lift, Sasa Sliders, Snorkel

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Probably one of those things you have to hear for yourself.
Things i would check
Make sure nuts and bolts on the coil bucket side are on or tight.
Other thing could be bushings going out and flexing the shock.

My UCA didnt look like the bushings were that bad till i removed them.

I have heard clicking sounds when turning and accelerating which has been do to bad cv joints.

Let us know what you find.

Will do


Hey Guys/Gals,

I'm getting this pinging sound like as if the coil spring was being strummed. Its really odd and only occurs when turning at low speeds. i mean just barley turning the steering wheel. I took it to the dealer since my X is only a yr old with 19k miles on it but they said everything looked good and if I wanted them to dig and troubleshoot it would cost me out of pocket because I have an "Aftermarket" suspension. Best part is a month after I bought my X (Bone Stock) I noticed the sound and took it in to have it looked at and of course the sound couldn't be duplicated for the mechanic and even when he went for a ride along with me. SO i have no idea and i'm pretty sure my little 2" spacer/aal isn't causing it because it did it stock. Any ideas? Thanks everyone

PS The sound is coming from the driver side front wheel well

I had same problem, before I removed my front swaybar. I don't know if when you added your "aftermarket suspension" you took the swaybar off or not, but when I removed mine, that problem never came back. The bolt on the driver side of mine was being torqued or like stressed more than normal, which was causing it to get hungup until it broke free and caused that thud sound. Removed, and haven't heard anything.

Thanks for the help I'll give that a try tomorrow and see. My sway bar is still on i only added the spacer and the AAL with no other modifications.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Jo-BOB

  • Sr. Member
  • ****
  • Posts: 327
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
What part of town are you in? I'd be happy to come help diagnosis and wrench with you if needed.
Thanks for the offer I was thinking about messing around with the truck this Sunday. I live on the North East side of town Catalina Hwy and Tanque Verde.
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline USAF2W1

  • Noob
  • *
  • Posts: 10
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #6 on: April 21, 2016, 04:36:42 PM »
So I spend 3 hours checking for anything obvious or loose hardware with no luck. I'm at the point where i don't care about the noises i just want to make sure my trucks not going to leave me stranded because that sound ended up being something serious. heres a short clip i made the sound. You can hear it 14 seconds in and at 23 seconds.
https://youtu.be/mlPw54Zda04
'15 X Sport 4x4
- 2" Nisstec Lift
- 285/75R16 BFG K02
- Melt Mod
- 15% Tint

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 854
  • Gender: Male
Re: Need Help my X is making an odd sound when turning
« Reply #7 on: April 21, 2016, 06:05:44 PM »
It does sounds like the spring being twisted and then it lets go.
Maybe send some pictures of the springs. I dont remember if there is a bushing for the top hat of the springs.