General Discussion > Open Discussions

Xterra Pulls to the left when braking

(1/2) > >>

Chuy:
After I did my last lift kit and SPC UCA's the Xterra is pulling to the left when braking. Any advice on what to look for?

Things I have done so far:

- Bleeded the brakes
- Checked right side caliper for clamping pressure
- Had the truck aligned twice at firestone

I'm guessing the alignment castor is off, or something is wrong with one of the calipers. My steering wheel is a little crooked to the right, but it seems to track straight on the freeway. Any advice is appreciated, Im about to give up and take it to the dealership again.


Thupertrooper (Victor):
I just troubleshooted this with a chevy truck and it was a pinched brake line.

But with your Xterra i would check your tie rods balljoints and bushings. Still sounds like a brake issue.

Chuy:

--- Quote from: Thupertrooper (Victor) on October 26, 2016, 04:00:09 PM ---I just troubleshooted this with a chevy truck and it was a pinched brake line.

But with your Xterra i would check your tie rods balljoints and bushings. Still sounds like a brake issue.

--- End quote ---

Tie rods are new, LCA's are new, and UCA is new, brake lines are after market stainless so that might be the culprit it may have collapsed inside.

Desert-X-Guy:
Chuy, you ever get to the bottom of this?  What was the culprit?

Chuy:

--- Quote from: Desert-X-Guy on April 27, 2017, 08:38:10 AM ---Chuy, you ever get to the bottom of this?  What was the culprit?

--- End quote ---

Wheel hub bearing, had it replaced and it tracks perfect now.

Navigation

[0] Message Index

[#] Next page

Go to full version