General Discussion > How To / DIY

Intake Manifold/Plenum Gasket Service

<< < (2/2)

pinchel (Rob):

--- Quote from: XterrasNameIsMolly (Justin) on January 18, 2017, 11:34:43 AM ---What a project, I am not sure I would be mechanically inclined enough to do this, kudos! I hope you figure it out

--- End quote ---

I'll figure it out. It's been slow going and on a budget so parts are coming slow. Main thing is cleaning it out a bit. I'm more concerned with the wire harness being so fragile. it's very possible that by time I'm done with this, that I may get another engine light for something electrical that wasn't an issue before. That is stressing me the most. :)

pinchel (Rob):
I should have taken a better before picture of the lower intake, but it's much cleaner now. Still working on it, then gotta move back to cleaning the engine bay, block and areas below the intake. I probably don't have to, but since I disturbed all the muck in there, it seems worthy of the job. Plus, I don't want to have to come back and take this apart anytime soon.

Pics coming

pinchel (Rob):
New gaskets and lower intake are back in, just gotta take pics and connect fuel rail back up then onto the top piece.

Here is the upper intake piece, sorry for the bad pic, but you can see the new 1/2" id hoses with the new clamps, and the small vacuum hoses.

pinchel (Rob):
What's done is done. Repairs were made. Truck is running normal. I had to go back and tighten a few hoses. There may be some minor seeping but I don't plan to take it apart unless I can see the coolant dripping after a few days.

These connections from the heater core were seeping coolant after the first start up. I might have loosened them and forgot to tighten.


I didn't replace the upper radiator hose and clamps but it is on order. I didn't think I'd need it immediately but after cleaning the inlet on the lower intake, the hose just isn't sealing. That part should be installed this week.

As far as I can tell no more visible coolant leaks, except the oil leak which is from the rear main seal. I thought it might be another minor coolant leak but hard to tell at the moment.

Navigation

[0] Message Index

[*] Previous page

Go to full version