collapse

Donate

Become a 2017/18 AZXC Supporting Member just Click the Donate button.

* Calendar

December 2017
Sun Mon Tue Wed Thu Fri Sat
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 [18] 19 20 21 22 23
24 25 26 27 28 29 30
31

No calendar events were found.

Upcoming Events

Sorry! There are no calendar events available at the moment.

* Newest Member

* Who's Online

  • Dot Guests: 18
  • Dot Hidden: 0
  • Dot Users: 1
  • Dot Users Online:

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • ShockBlue_Scott: Seems like a good deal not sure if it is some one on here: [link]
    December 15, 2017, 11:53:37 AM
  • pinchel (Rob): Definitely breaker bar...
    December 15, 2017, 08:27:59 AM
  • PitSnipe (Kyle): No, Thats best acomplished with a breaaker bar and a wrench.
    December 14, 2017, 09:02:10 PM
  • ShockBlue_Scott: You think it will bust the lower shock bolts loose?
    December 14, 2017, 08:51:05 PM
  • PitSnipe (Kyle): I have a 3/8 drive Milwaukee cordless impact
    December 14, 2017, 08:47:31 PM
  • ShockBlue_Scott: @PitSnipe what size is your?
    December 14, 2017, 08:46:22 PM
  • PitSnipe (Kyle): cant help ya there.
    December 14, 2017, 08:29:38 PM
  • ShockBlue_Scott: @PitSnipe prefer 1/2 as I wanna do the suspension on the truck. But if  3/8 will work...
    December 14, 2017, 08:14:55 PM
  • PitSnipe (Kyle): 3/8 or 1/2 ?
    December 14, 2017, 05:45:19 PM
  • ShockBlue_Scott: Anyone have a good cordless impact gun I could borrow for a few days?
    December 14, 2017, 01:59:48 PM
  • pinchel (Rob): Happy Holidays!
    December 13, 2017, 09:56:41 PM
  • pinchel (Rob): Post up if you can meet up at Coffee & Crawlers tomorrow! Don't forget a new unwrapped toy to enter special drawing.
    December 08, 2017, 06:02:36 PM
  • ShockBlue_Scott: Has anyone done the Diamond Creek Road to the bottom of the Grand Canyon?
    December 05, 2017, 08:52:10 AM
  • XterrasNameIsMolly (Justin): I have nothing to do, but I would be happy to assist / host a mod day if interested (south phoenix)
    December 05, 2017, 08:47:14 AM
  • DBAX: Picked up a pop up camper (used) this weekend, thinking an axle flip will be a good thing. Also thinking, I've never flipped an axle..
    December 04, 2017, 01:28:38 PM
  • ShockBlue_Scott: I would be interested in a mod day and helping others. I have some Pro 4x suspension that needs to go in...
    December 04, 2017, 08:15:24 AM
  • Thupertrooper (Victor): I can try hosting a mod day in the east valley if we have some interested to help out
    December 01, 2017, 09:59:52 PM
  • pinchel (Rob): As soon as i get my bolts i can have a mod day
    December 01, 2017, 02:23:19 PM
  • m.sainz12: also whens the next mod day
    November 30, 2017, 05:48:21 PM
  • m.sainz12: no not yet! he wont text me back :(
    November 30, 2017, 05:48:03 PM

Author Topic: P0340- who's had it?  (Read 472 times)

0 Members and 1 Guest are viewing this topic.

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
P0340- who's had it?
« on: February 17, 2017, 04:14:25 PM »
About a month ago my 07 OR had a really rough idle at start up. SES came on, then it smoothed out, RPMs went normal and the light went out. A week ago the engine kind of 'hiccuped' on the highway fie just a moment. That night it didn't want to start and when it finally cranked over the VDC, SLIP, and SES lights were on and have been ever since. Read the code with my Superchips and it gave me P0340- passenger side bank 1 camshaft position sensor.

Who's had this come up and did an install of a new sensor fix the problem for good? Any installation tips?


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 753
  • Gender: Male
Re: P0340- who's had it?
« Reply #1 on: February 17, 2017, 04:21:03 PM »
I think Avi has had issues with this. Just swapped it out.

Offline pinchel (Rob)

  • Club Treasurer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1684
  • Gender: Male
  • "He who laughs last, laughs last."
    • robakapinchel
    • pinchel
    • pinchel
    • VinylTats
Re: P0340- who's had it?
« Reply #2 on: February 18, 2017, 03:34:48 PM »
Yep, Avi did, and a neighbor did. Both replaced the sensor and it fixed it. The sensor is a PITA but not too terrible.
Click here to see my rig.  Get your AZXC/AZTC/AZFC Forum Decals here  VinylTats!

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #3 on: March 13, 2017, 12:00:37 AM »
So for anyone who searches this in the future, here's a few pics. Easiest way to get to the bank 1 (passenger side/right side) camshaft position sensor is with a step stool by the passenger side tire and reach in here.

You have to kind of weave your hand in between a couple wire harnesses and you'll feel a smooth skinnier wire harness. Follow this back to the back of the engine and that's the sensor. You'll feel a large rectangular harness connector. On the bottom is the release. Push it in towards the front of the vehicle and it should release.

Here is where it's easiest to lay on top of the engine bay and reach down with a 10mm to remove the actual sensor. I couldn't get the harness connector to release while attached and had to remove the sensor and then the connector.
This is what the sensor looks like.



Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1841
  • Gender: Male
Re: P0340- who's had it?
« Reply #4 on: March 13, 2017, 12:09:13 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #5 on: March 13, 2017, 12:10:34 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing.
That stupid connector! It wouldn't come off! Heather is the one that got her little hand in there with a mini socket. Lol


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1841
  • Gender: Male
Re: P0340- who's had it?
« Reply #6 on: March 13, 2017, 04:29:44 AM »
I've sprayed them with wd40, seems to help that little latch move. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #7 on: March 13, 2017, 06:37:17 AM »
I got the latch to slide forward, but the connecter wouldn't come undone. I actually had to grab the old sensor with pliers to get it off the connector. Also when the old one came out, the o-ring seal was got. I assume rotted away or cracked and fell off when I removed it.


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...