collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2018 AZXC Supporting Member just Click the Donate button.

* Calendar

July 2018
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 [19] 20 21
22 23 24 25 26 27 28
29 30 31

No calendar events were found.

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 37
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • pinchel (Rob): Anyone know a massage therapist who would be willing to donate their time at Flag2GC?
    July 09, 2018, 05:02:37 PM
  • pinchel (Rob): We're in the the last month before Flag2GC!
    July 01, 2018, 07:51:18 AM
  • pinchel (Rob): not sure why you cant post
    June 24, 2018, 01:16:17 PM
  • roadrash76: Oh yeah I have a new E-Class, but that was a trade for my Lexus.  The Xterra was just a flat out sale for cash.
    June 22, 2018, 02:59:52 PM
  • Thupertrooper (Victor): Well I just figured out who you were and rumor has it you got a sweet Mercedes lol
    June 21, 2018, 07:14:42 PM
  • roadrash76: I can't post an ad here.  No matter how many times I try.
    June 21, 2018, 04:23:52 PM
  • roadrash76: Nothing.  I just sold it.  Wanted the cash.
    June 21, 2018, 04:17:20 PM
  • Thupertrooper (Victor): Gotcha. That a shame about the Xterra though what you replace it with?
    June 21, 2018, 05:16:26 AM
  • roadrash76: Yes Vic, exactly that
    June 20, 2018, 07:01:00 PM
  • Thupertrooper (Victor): Extended as in stock R180 to titan swap length?
    June 19, 2018, 12:16:56 PM
  • roadrash76: The CV axles are extended axles
    June 18, 2018, 06:51:57 PM
  • roadrash76: $500 OBO
    June 18, 2018, 06:36:24 PM
  • PitSnipe (Kyle): How much?
    June 17, 2018, 06:05:47 PM
  • Thupertrooper (Victor): Perfect for anybody titan swapping or trail spares
    June 16, 2018, 02:12:48 PM
  • roadrash76: I have Titan CV axles and Lower CA's I no longer need
    June 15, 2018, 07:17:05 PM
  • roadrash76: I sold my 2014 Xterra PRO 4X
    June 15, 2018, 07:16:29 PM
  • xterra07: link: [link]
    June 15, 2018, 11:14:28 AM
  • xterra07: P0448 - I think that was the code on my 2007 that kept appearing 5-10 times a year, I cleared it with ODBC II software. Mechanic said it effects emissions but I passed emissions with it.
    June 15, 2018, 11:11:45 AM
  • Desertrunner2169: Has anyone ever seen the code P0448 in a code reader
    June 14, 2018, 10:22:19 PM
  • Thupertrooper (Victor): Anybody want to buy my 33" mud terrains?
    June 14, 2018, 08:14:27 AM
GoTo RockAuto Vinyltats Nissan Accessories & Parts at CARiD.com
Combat Wipes The Scrubblade Advantage
CVT Tents and Awnings Nissan Accessories & Parts at CARiD.com Nissan Accessories & Parts at CARiD.com

Author Topic: P0340- who's had it?  (Read 702 times)

0 Members and 1 Guest are viewing this topic.

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
P0340- who's had it?
« on: February 17, 2017, 04:14:25 PM »
About a month ago my 07 OR had a really rough idle at start up. SES came on, then it smoothed out, RPMs went normal and the light went out. A week ago the engine kind of 'hiccuped' on the highway fie just a moment. That night it didn't want to start and when it finally cranked over the VDC, SLIP, and SES lights were on and have been ever since. Read the code with my Superchips and it gave me P0340- passenger side bank 1 camshaft position sensor.

Who's had this come up and did an install of a new sensor fix the problem for good? Any installation tips?


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 842
  • Gender: Male
Re: P0340- who's had it?
« Reply #1 on: February 17, 2017, 04:21:03 PM »
I think Avi has had issues with this. Just swapped it out.

Offline pinchel (Rob)

  • Club Treasurer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1800
  • Gender: Male
  • "He who laughs last, laughs last."
    • robakapinchel
    • pinchel
    • pinchel
    • VinylTats
Re: P0340- who's had it?
« Reply #2 on: February 18, 2017, 03:34:48 PM »
Yep, Avi did, and a neighbor did. Both replaced the sensor and it fixed it. The sensor is a PITA but not too terrible.
Click here to see my rig.  Get your AZXC/AZTC/AZFC Forum Decals here  VinylTats!

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #3 on: March 13, 2017, 12:00:37 AM »
So for anyone who searches this in the future, here's a few pics. Easiest way to get to the bank 1 (passenger side/right side) camshaft position sensor is with a step stool by the passenger side tire and reach in here.

You have to kind of weave your hand in between a couple wire harnesses and you'll feel a smooth skinnier wire harness. Follow this back to the back of the engine and that's the sensor. You'll feel a large rectangular harness connector. On the bottom is the release. Push it in towards the front of the vehicle and it should release.

Here is where it's easiest to lay on top of the engine bay and reach down with a 10mm to remove the actual sensor. I couldn't get the harness connector to release while attached and had to remove the sensor and then the connector.
This is what the sensor looks like.



Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1844
  • Gender: Male
Re: P0340- who's had it?
« Reply #4 on: March 13, 2017, 12:09:13 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #5 on: March 13, 2017, 12:10:34 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing.
That stupid connector! It wouldn't come off! Heather is the one that got her little hand in there with a mini socket. Lol


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1844
  • Gender: Male
Re: P0340- who's had it?
« Reply #6 on: March 13, 2017, 04:29:44 AM »
I've sprayed them with wd40, seems to help that little latch move. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #7 on: March 13, 2017, 06:37:17 AM »
I got the latch to slide forward, but the connecter wouldn't come undone. I actually had to grab the old sensor with pliers to get it off the connector. Also when the old one came out, the o-ring seal was got. I assume rotted away or cracked and fell off when I removed it.


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...