collapse

Donate Flag2GC

Donate to Toys for Tots!
Become a 2018 AZXC Supporting Member just Click the Donate button.

* Calendar

April 2018
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 [19] 20 21
22 23 24 25 26 27 28
29 30

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 33
  • Dot Hidden: 0
  • Dot Users: 1
  • Dot Users Online:

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • ShockBlue_Scott: Victor I voted for you. Best of luck
    Today at 09:53:51 AM
  • Thupertrooper (Victor): Entered my Pathy in the overland cool ride contest lets see if its rigged.       [link]
    Yesterday at 03:48:51 PM
  • ShockBlue_Scott: anyone have a stock radio bracket?
    April 16, 2018, 08:33:57 PM
  • Thupertrooper (Victor): The waiting game
    April 14, 2018, 08:43:41 PM
  • m.sainz12: titan LCAs and tie rods came in yesterday! cant belive how big they look.now just waiting on UCAs Coilovers and brake lines. should be about 2 more weeks!
    April 14, 2018, 10:27:53 AM
  • pinchel (Rob): Hello Hughe!
    April 11, 2018, 08:21:52 PM
  • pinchel (Rob): Many of us will be in Sedona
    April 11, 2018, 08:21:26 PM
  • ShockBlue_Scott: anyone going to the off road expo?
    April 11, 2018, 07:11:41 PM
  • Thupertrooper (Victor): Got some time to update the Sedona Run   [link]
    April 10, 2018, 08:34:55 PM
  • Thupertrooper (Victor): Happy Birthday Rubio480 (Eron)
    April 09, 2018, 02:58:49 PM
  • pinchel (Rob): I can, but don't expect it soon. lol
    April 08, 2018, 09:51:11 AM
  • ShockBlue_Scott: Pinchel since you have a 1st Gen would you be willing to mock up using cardboard the skids? I will mock up the 2nd Gens if someone has not done so already.
    April 08, 2018, 08:47:44 AM
  • pinchel (Rob): depends on the material but personally id rather have aluminum
    April 08, 2018, 08:41:30 AM
  • ShockBlue_Scott: My neighbor works with a water jet and might be able to make skids for us. How many would be interested if he can? What is the normal thickness so I can give him an idea, also aluminum or steel?
    April 08, 2018, 07:15:18 AM
  • Thupertrooper (Victor): Im going to have to check that tool AZ-Ted my trans overheated on me once on the trail.
    April 06, 2018, 02:27:39 PM
  • AZ-Ted: there is a thread on thenewx about it in the Electrical section
    April 06, 2018, 01:50:48 PM
  • AZ-Ted: Hey AZXC, did you see Scan Gauge can now read transmission temps?!?!
    April 06, 2018, 01:50:23 PM
  • ShockBlue_Scott: Thank you Pinchel. I logged on a few seconds ago and was a little caught off guard. Seen an ad and thought I was logged out... LOL
    April 03, 2018, 07:34:35 PM
  • pinchel (Rob): Limited amount of long sleeves and hoodies now available!
    April 02, 2018, 08:48:53 PM
  • pinchel (Rob): Welcome ShockBlue_Scott to our Supporting Members!
    April 02, 2018, 08:46:01 PM
GoTo RockAuto Vinyltats Nissan Accessories & Parts at CARiD.com
Combat Wipes The Scrubblade Advantage
CVT Tents and Awnings Nissan Accessories & Parts at CARiD.com Nissan Accessories & Parts at CARiD.com

Author Topic: P0340- who's had it?  (Read 608 times)

0 Members and 1 Guest are viewing this topic.

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
P0340- who's had it?
« on: February 17, 2017, 04:14:25 PM »
About a month ago my 07 OR had a really rough idle at start up. SES came on, then it smoothed out, RPMs went normal and the light went out. A week ago the engine kind of 'hiccuped' on the highway fie just a moment. That night it didn't want to start and when it finally cranked over the VDC, SLIP, and SES lights were on and have been ever since. Read the code with my Superchips and it gave me P0340- passenger side bank 1 camshaft position sensor.

Who's had this come up and did an install of a new sensor fix the problem for good? Any installation tips?


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Thupertrooper (Victor)

  • AZXC Event Coordinator
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 800
  • Gender: Male
Re: P0340- who's had it?
« Reply #1 on: February 17, 2017, 04:21:03 PM »
I think Avi has had issues with this. Just swapped it out.

Offline pinchel (Rob)

  • Club Treasurer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1735
  • Gender: Male
  • "He who laughs last, laughs last."
    • robakapinchel
    • pinchel
    • pinchel
    • VinylTats
Re: P0340- who's had it?
« Reply #2 on: February 18, 2017, 03:34:48 PM »
Yep, Avi did, and a neighbor did. Both replaced the sensor and it fixed it. The sensor is a PITA but not too terrible.
Click here to see my rig.  Get your AZXC/AZTC/AZFC Forum Decals here  VinylTats!

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #3 on: March 13, 2017, 12:00:37 AM »
So for anyone who searches this in the future, here's a few pics. Easiest way to get to the bank 1 (passenger side/right side) camshaft position sensor is with a step stool by the passenger side tire and reach in here.

You have to kind of weave your hand in between a couple wire harnesses and you'll feel a smooth skinnier wire harness. Follow this back to the back of the engine and that's the sensor. You'll feel a large rectangular harness connector. On the bottom is the release. Push it in towards the front of the vehicle and it should release.

Here is where it's easiest to lay on top of the engine bay and reach down with a 10mm to remove the actual sensor. I couldn't get the harness connector to release while attached and had to remove the sensor and then the connector.
This is what the sensor looks like.



Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1843
  • Gender: Male
Re: P0340- who's had it?
« Reply #4 on: March 13, 2017, 12:09:13 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #5 on: March 13, 2017, 12:10:34 AM »
Good job, I should of written it up one of the 4 times I've done it, but I was always too busy cursing.
That stupid connector! It wouldn't come off! Heather is the one that got her little hand in there with a mini socket. Lol


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...

Offline Hammer (Avi)

  • Club President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1843
  • Gender: Male
Re: P0340- who's had it?
« Reply #6 on: March 13, 2017, 04:29:44 AM »
I've sprayed them with wd40, seems to help that little latch move. 
PRG Advanced lift
Xoskel Sliders and Roof Rack
Full skids

Offline coatimundi01

  • Full Member
  • ***
  • Posts: 210
  • Gender: Male
Re: P0340- who's had it?
« Reply #7 on: March 13, 2017, 06:37:17 AM »
I got the latch to slide forward, but the connecter wouldn't come undone. I actually had to grab the old sensor with pliers to get it off the connector. Also when the old one came out, the o-ring seal was got. I assume rotted away or cracked and fell off when I removed it.


Sent from my iPhone using Tapatalk
Wishin' I was fishin'...