collapse

Donate

Become a 2017/18 AZXC Supporting Member just Click the Donate button.

* Calendar

November 2017
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 [17] 18
19 20 21 22 23 24 25
26 27 28 29 30

No calendar events were found.

Upcoming Events

* Newest Member

* Who's Online

  • Dot Guests: 18
  • Dot Hidden: 0
  • Dot Users: 1
  • Dot Users Online:

* User Info

 
 
Welcome, Guest. Please login or register.
goto AZXC

Go To AZXC

goto AZTC

GoTo AZFC

GoTo AZPC

Forum Chatbox

Refresh History
  • pinchel (Rob): New Club patches are coming soon...pics just posted! Who wants some?! [link]
    Today at 06:37:09 PM
  • pinchel (Rob): There's a few members in Tucson, but not sure what their availability is.
    Today at 10:44:00 AM
  • cjohan: anyone in tucson? need to do the bypass but would rather have help then do it myself
    November 15, 2017, 07:43:18 PM
  • HBIII: Thanks, I will check them out
    November 12, 2017, 02:40:02 PM
  • Thupertrooper (Victor): Phx rack and axle has lifetime replacement on there rack and pinions.
    November 12, 2017, 10:44:55 AM
  • pinchel (Rob): Sounds like your replacement rack was bad.
    November 12, 2017, 08:28:27 AM
  • HBIII: The assembly is leaking in both sides and the boots on the inner tie rods are both ripped open leading them to believe it is all related. Sorry I'm not the best with suspension knowledge
    November 10, 2017, 03:14:54 PM
  • cjohan: inner tie rods?
    November 10, 2017, 02:18:28 PM
  • HBIII: Inner tie rods
    November 10, 2017, 02:11:18 PM
  • PitSnipe (Kyle): fans are controlled by the coolant temp. When coolant temp is above specified temp the fans will come on.
    November 10, 2017, 01:36:02 PM
  • cjohan: anyone have there fans come on with engine? a/c and heat off
    November 10, 2017, 01:19:49 PM
  • PitSnipe (Kyle): where exactly did it fail?
    November 10, 2017, 12:48:52 PM
  • HBIII: The factory rack failed at 48k miles and now the replacement just failed at 71k miles and I don't know why
    November 10, 2017, 06:41:15 AM
  • PitSnipe (Kyle): Elaborate "eat steering assembly"
    November 10, 2017, 03:53:49 AM
  • HBIII: Preferably in the valley. Thanks
    November 10, 2017, 12:21:39 AM
  • HBIII: Anyone have recommendation for someone that can diagnose an issue causing my X to eat steering assemblies?
    November 10, 2017, 12:20:59 AM
  • Forrest: Charouleau gap is a fun but difficult trail I try to go up there once a month
    November 09, 2017, 07:46:05 AM
  • 14Frontier: I have been up to kiss rock on the gap
    November 07, 2017, 05:37:40 PM
  • remo1991(Brent): Yup fun trail
    November 05, 2017, 07:00:20 AM
  • m.sainz12: anyone ever run charouleau gap in tucson?
    November 05, 2017, 06:49:07 AM

Author Topic: Front end has a clunking sound  (Read 77 times)

0 Members and 1 Guest are viewing this topic.

Offline Steve

  • Noob
  • *
  • Posts: 16
  • Gender: Male
    • Steve.gorski.92
Front end has a clunking sound
« on: November 04, 2017, 10:41:35 AM »
I installed the nisstec mk84 coilovers and spc uca's and there is a clunking sound sometimes. Everything seems tight, I just can't find were it's coming from. Any help would be great thanks.


Sent from my iPad using Tapatalk

Offline PitSnipe (Kyle)

  • Club Vice President
  • Administrator
  • Hero Member
  • *****
  • Posts: 1412
  • Gender: Male
    • Kyle Zastrow
    • xterraguy81
Re: Front end has a clunking sound
« Reply #1 on: November 04, 2017, 11:18:32 AM »
Make sure everything is tight. Usually everything needs to be retightened after about 500 miles due to settling.
Eight Time ToTM Winner. July 2013, December 2013, July 2014, December 2014, May 2015, August 2016, February 2017, September 2017

Offline Steve

  • Noob
  • *
  • Posts: 16
  • Gender: Male
    • Steve.gorski.92
Re: Front end has a clunking sound
« Reply #2 on: November 04, 2017, 11:26:23 AM »
Ok, I will retighten everything and see how it goes


Sent from my iPhone using Tapatalk

Offline pinchel (Rob)

  • Club Treasurer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1678
  • Gender: Male
  • "He who laughs last, laughs last."
    • robakapinchel
    • pinchel
    • pinchel
    • VinylTats
Re: Front end has a clunking sound
« Reply #3 on: November 04, 2017, 06:07:22 PM »
Was the noise there right after you did this?
Click here to see my rig.  Get your AZXC/AZTC/AZFC Forum Decals here  VinylTats!

Offline Steve

  • Noob
  • *
  • Posts: 16
  • Gender: Male
    • Steve.gorski.92
Re: Front end has a clunking sound
« Reply #4 on: November 04, 2017, 06:18:55 PM »
No, it was there before I did the shocks. It did it with the spacers on the stock shocks. I was hoping it was my old shocks, apparently not


Sent from my iPhone using Tapatalk

Offline Steve

  • Noob
  • *
  • Posts: 16
  • Gender: Male
    • Steve.gorski.92
Re: Front end has a clunking sound
« Reply #5 on: November 05, 2017, 04:56:15 PM »
I'm pretty sure I found the problem, one of my cam bolts was a little loose. I drove it a little today and no noise


Sent from my iPad using Tapatalk